PDA

View Full Version : my pic in someone else's gallery


PikminLink
05-15-2004, 10:47 PM
*this is pikminlinks brother "Master Jedi".*
a couple of weeks ago, when I loaded my pic, I accidentaly loaded under a different heading instead of member galleries, and then it somehow ended up under someone else's gallery. I'm attaching a link to the page. can you help?

Thanks,
Master Jedi

http://images.cosplay.com/showphoto.php?photo=132407&password=b55f2c5b0063ace3f22726bdb2ec6ffc&sort=1&cat=all&page=1

Cherry
05-16-2004, 04:10 AM
o_o; That's a bit weird....

allyunion
05-16-2004, 08:02 AM
Hmm... Well, it's not linking to Bobbi's gallery, it's still linking to yours.


Bobbi's user ID is 539
MasterJedi's user ID is 6718

Difference between these two numbers is 6179. This particular number is not a related to a power of 2, or a multiple of 1024.

What is occurring here is something wrong in either the code or the database which has caused a hiccup. The hashing for the username using the number 6179 somehow produced Bobbi's name for that particular page. I don't know the script details, but what it seems to me is that the database reference is incorrect.

If I'm not mistaken, the database value when it looks up this photo, has Bobbi as the member name in one of the fields as not every field is looked up each time, thereby cutting the number of database queries or what not. The webpage is statically built, to a certain extent, and saved under the reference number.

My guess is that during the upload or publishing process, some data was corrupted, which cause the number to be passed to be 539 when looking up the username with the corresponding user ID.


Anyway, it's sufficient to say that something screwed up somewhere. If this is a bug, this won't be too completely easy to track.

lainey
05-17-2004, 12:05 AM
can u delete it...?
or can bobbi delete it...?

lol

allyunion
05-17-2004, 03:51 AM
I think deleting it and reposting it might fix this error.